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Salesforce Certified Tableau Consultant Sample Questions (Q38-Q43):
NEW QUESTION # 38 
A client has several long-term shipping contracts with different vendors that set rates based on shipping volume and speed. The client
requests a dashboard that allows them to model shipping costs for the next week based on the selected shipping vendor. Speed for
the end user is critical.
Which dashboard building strategy will deliver the desired result?

A. Calculate the potential shipping cost for each order with each vendor, display the aggregate costs in a large table, and use
quick filters to limit the options visible to the user.
B. Recommend that the client model for only profitability for the next 24 hours instead of a full week.
C. Aggregate the orders then use a calculated field that refers to a user-selected parameter to calculate the shipping costs.
D. Use a calculated field that refers to a user-selected parameter to calculate shipping costs for each order and then display
the aggregate values.

Answer: D

Explanation:
For modeling shipping costs based on varying vendor contracts and ensuring speed in dashboard performance, the suggested
approach involves:
Calculated Field with Parameter: Utilize a calculated field that dynamically references a user-selected parameter for the shipping
vendor. This parameter adjusts the cost calculations based on selected vendor characteristics (like volume and speed).
Aggregate Results: After calculating individual shipping costs, aggregate these costs to provide a concise, summarized view of

https://drive.google.com/open?id=1hNAChTs63g6pkN8LJa8we2Wy9txu1VZK
https://www.prep4away.com/Salesforce-certification/braindumps.Analytics-Con-301.ete.file.html
https://www.examdiscuss.com/Salesforce/exam/Analytics-Con-301/questions/
https://www.actualpdf.com/Analytics-Con-301_exam-dumps.html
https://www.prep4sures.top/Analytics-Con-301-exam-dumps-torrent.html


potential expenses for the upcoming week. This method ensures the dashboard remains performant by reducing the load of
processing individual line items in real-time.
Why This Works: By using parameters and calculated fields, the dashboard can quickly adapt to user inputs without needing to re-
query the entire dataset. Aggregating the results further improves performance and user experience by simplifying the output.
References
This strategy leverages Tableau's capability to handle dynamic calculations with parameters and is recommended for scenarios where
performance and user-driven interaction are priorities. Tableau's performance optimization resources and dashboard design
guidelines detail these techniques.

NEW QUESTION # 39 
A stakeholder has multiple files saved (CSV/Tables) in a single location. A few files from the location are required for analysis. Data
transformation (calculations) is required for the files before designing the visuals. The files have the following attributes:
. All files have the same schema.
. Multiple files have something in common among their file names.
. Each file has a unique key column.
Which data transformation strategy should the consultant use to deliver the best optimized result?

A. Use wildcard Union option to combine/merge all the files together before doing the data transformation (calculations).
B. Apply the data transformation (calculations) in each require file and do the wildcard union to combine
/merge before designing the visuals.
C. Use join option to combine/merge all the files together before doing the data transformation (calculations).
D. Apply the data transformation (calculations) in each require file and do the join to combine/merge before designing the
visuals.

Answer: A

Explanation:
Moving calculations to the data layer and materializing them in the extract can significantly improve the performance of reports in
Tableau. The calculation ZN([Sales])*(1 - ZN([Discount])) is a basic calculation that can be easily computed in advance and stored
in the extract, speeding up future queries. This type of calculation is less complex than table calculations or LOD expressions, which
are better suited for dynamic analysis and may not benefit as much from materialization12.
References: The answer is based on the best practices for creating efficient calculations in Tableau, as described in Tableau's official
documentation, which suggests using basic and aggregate calculations to improve performance1. Additionally, the process of
materializing calculations in extracts is detailed in Tableau's resources2.
Given that all files share the same schema and have a common element in their file names, the wildcard union is an optimal approach
to combine these files before performing any transformations. This strategy offers the following advantages:
Efficient Data Combination: Wildcard union allows multiple files with a common naming scheme to be combined into a single dataset
in Tableau, streamlining the data preparation process.
Uniform Schema Handling: Since all files share the same schema, wildcard union ensures that the combined dataset maintains
consistency in data structure, making further data manipulation more straightforward.
Pre-Transformation Combination: Combining the files before applying transformations is generally more efficient as it reduces
redundancy in transformation logic across multiple files. This means transformations are written and processed once on the unified
dataset, rather than repeatedly for each individual file.
References:
Wildcard Union in Tableau: This feature simplifies the process of combining multiple similar files into a single Tableau data source,
ensuring a seamless and efficient approach to data integration and preparation.

NEW QUESTION # 40 
A client's dashboard has two sections dedicated to their shops and warehouses shown when a viewer chooses either shops or
warehouses with a parameter.
There are a few quick filters that apply to both, while others apply to only shops or only warehouses.
Currently, the quick filters are all shown at the left side of the dashboard. The client wants to hide all filters, but when shown, make it
easy for the viewer to find the quick filters that work for only shops or only warehouses.
Which solution should the consultant recommend that meets the client's needs and is most user-friendly?

A. Hide container with all quick filters with a Show/Hide Button.
B. Use Dynamic Zone Visibility to show only the quick filters that apply with the chosen parameter value and a Show/Hide
Button to hide container with all the filters.



C. Use Dynamic Zone Visibility to inform viewers which quick filters apply to warehouses or shops.
D. Divide the quick filters into three groups: General, for shops. Place the general filters on the left of dashboard for
warehouses. Place other filters next to the sections to which they apply.

Answer: B

Explanation:
The most user-friendly solution is to use Dynamic Zone Visibility in combination with a Show/Hide Button. This approach allows the
dashboard to dynamically display only the relevant quick filters based on the viewer's selection of shops or warehouses, thus
reducing clutter and focusing the user's attention on applicable filters. The Show/Hide Button further enhances the user experience by
allowing viewers to toggle the visibility of the filter container, providing a clean and organized dashboard interface1.
References: Dynamic Zone Visibility is a feature in Tableau that enables dashboard elements to appear or disappear based on the
value of a field or parameter1. This functionality is ideal for creating interactive and user-friendly dashboards that adapt to user
interactions and selections1.

NEW QUESTION # 41 
A Tableau Cloud client has requested a custom dashboard to help track which data sources are used most frequently in dashboards
across their site.
Which two actions should the client use to access the necessary metadata? Choose two.

A. Query metadata through the GraphiQL engine.
B. Download metadata through Tableau Catalog.
C. Access metadata through the Metadata API.
D. Connect directly to the Site Content data source within the Admin Insights project.

Answer: A,C

Explanation:
To track which data sources are used most frequently across a site in Tableau Cloud, the client should use the GraphiQL engine and
the Metadata API. The GraphiQL engine allows for interactive exploration of the metadata, making it easier to construct and test
queries1. The Metadata API provides access to metadata and lineage of external assets used by the content published to Tableau
Cloud, which is essential for tracking data source usage2.
References: The actions are based on the capabilities of the GraphiQL engine and the Metadata API as described in Tableau's
official documentation and learning resources321.

NEW QUESTION # 42 
SIMULATION
Refer to the exhibit.
From the desktop, open the NYC
Property Transactions workbook.
You need to record the performance of
the Property Transactions dashboard in
the NYC Property Transactions.twbx
workbook. Ensure that you start the
recording as soon as you open the
workbook. Open the Property
Transactions dashboard, reset the filters
on the dashboard to show all values, and
stop the recording. Save the recording in
C:\CC\Data\.
Create a new worksheet in the
performance recording. In the worksheet,
create a bar chart to show the elapsed
time of each command name by
worksheet, to show how each sheet in
the Property Transactions dashboard
contributes to the overall load time.
From the File menu in Tableau Desktop,



click Save. Save the performance
recording in C:\CC\Data\.

Answer:

Explanation:
See the complete Steps below in Explanation
Explanation:
To record the performance of the Property Transactions dashboard in the NYC Property Transactions.twbx workbook and analyze
it using a bar chart, follow these detailed steps:
Open the NYC Property Transactions Workbook:
From the desktop, double-click the NYC Property Transactions.twbx workbook to open it in Tableau Desktop.
Start Performance Recording:
Before doing anything else, navigate to the 'Help' menu in Tableau Desktop.
Select 'Settings and Performance', then choose 'Start Performance Recording'.
Open the Property Transactions Dashboard and Reset Filters:
Navigate to the Property Transactions dashboard within the workbook.
Reset all filters to show all values. This usually involves selecting the dropdown on each filter and choosing 'All' or using a 'Reset'
button if available.
Stop the Performance Recording:
Go back to the 'Help' menu.
Choose 'Settings and Performance', then select 'Stop Performance Recording'.
Tableau will automatically open a new tab displaying the performance recording results.
Save the Performance Recording:
In the performance recording results tab, go to the 'File' menu.
Click 'Save As' and navigate to the C:\CC\Data\ directory.
Save the file, ensuring it is stored in the desired location.
Create a New Worksheet for Performance Analysis:
Return to the NYC Property Transactions workbook and create a new worksheet by clicking on the 'New Worksheet' icon.
Drag the 'Command Name' field to the Columns shelf.
Drag the 'Elapsed Time' field to the Rows shelf.
Ensure that the 'Worksheet' field is also included in the analysis to break down the time by individual sheets within the dashboard.
Choose 'Bar Chart' from the 'Show Me' options to display the data as a bar chart.
Customize and Finalize the Bar Chart:
Adjust the axes and labels to clearly display the information.
Format the chart to enhance readability, applying color coding or sorting as needed to emphasize sheets with longer load times.
Save Your Work:
Once the new worksheet and the performance recording are complete, ensure all work is saved.
Navigate to the 'File' menu and click 'Save', confirming that changes are stored in the workbook.
References:
Tableau Help Documentation: Provides guidance on how to start and stop performance recordings and analyze them.
Tableau Visualization Techniques: Offers tips on creating effective bar charts for performance data.
By following these steps, you have successfully recorded and analyzed the performance of the Property Transactions dashboard,
providing valuable insights into how each component of the dashboard contributes to the overall load time. This analysis is crucial for
optimizing dashboard performance and ensuring efficient data visualization.

NEW QUESTION # 43
......
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