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58. Frage 
A Tableau consultant is tasked with choosing a method of setting up row-level security (RLS) entitlements with tables during a
Tableau implementation. The consultant has received a set of roles from a client in one normalized table, and a set of entitlements
from the client in another normalized table.
The consultant plans on using the deepest granularity method. However, when the consultant gains access to the final set of data,
they discover duplicate values at the lowest level. Most of the regions in the client's dataset contain sub-regions named 'East' and
'West'. However, some regions have a 'Null' value for sub-region.
How should the consultant proceed?

A. Use the deepest granularity method because it is the most performant and the duplicate values will be handled by the
mapping table.
B. Use sparse entitlements because it is the most performant and the duplicate values will be handled by the mapping table.
C. Use the deepest granularity method because it defines entitlements at every level of the hierarchy and can handle duplicate
values in the dataset.
D. Use sparse entitlements because it defines entitlements at every level of the hierarchy and can handle duplicate values in the
dataset.

Antwort: D

Begründung:
Comprehensive and Detailed Explanation From Exact Extract:
Tableau's RLS entitlement design patterns include:
1. Deepest Granularity Method
* Requires one unique role # one unique lowest-level value pairing.
* Fails when the dataset contains duplicate lowest-level values (e.g., multiple "East" sub-regions across different regions).
* Cannot operate correctly when some lowest-level values are NULL.
Thus, the deepest granularity method is not valid here.
2. Sparse Entitlements Method
Tableau documentation states:
* Sparse entitlements define RLS at each level of the hierarchy instead of only at the lowest level.
* This method supports duplicate lowest-level values.
* Handles scenarios where some levels are NULL because higher-level entitlements (e.g. Region = AMER) can still correctly apply.
* More flexible for hierarchical geographic structures (Region # Sub-Region # Country, etc.).
Given the client's dataset:
* Multiple "East" and "West" sub-regions
* Some "Null" sub-regions
* Hierarchical levels present
Sparse entitlements is the only correct and supported choice.
Why the incorrect options are wrong:
A & B - Deepest Granularity
* Deepest granularity fails when the lowest-level values are not unique.
* It cannot handle NULL values at the lowest tier.
* Performance is not superior in this scenario.
D - Sparse because it is most performant
Performance is not the defining advantage.
Flexibility and ability to handle duplicate lowest-level values is.
Thus, C is the correct statement.
* RLS entitlement design patterns: deepest vs. sparse entitlements.
* Rules requiring unique lowest-level identifiers for deepest granularity.
* Guidance stating sparse entitlements should be used when duplicates or NULL values exist in hierarchical structures.

59. Frage 
SIMULATION
Refer to the exhibit.
From the desktop, open the NYC
Property Transactions workbook.
You need to record the performance of
the Property Transactions dashboard in
the NYC Property Transactions.twbx



workbook. Ensure that you start the
recording as soon as you open the
workbook. Open the Property
Transactions dashboard, reset the filters
on the dashboard to show all values, and
stop the recording. Save the recording in
C:\CC\Data\.
Create a new worksheet in the
performance recording. In the worksheet,
create a bar chart to show the elapsed
time of each command name by
worksheet, to show how each sheet in
the Property Transactions dashboard
contributes to the overall load time.
From the File menu in Tableau Desktop,
click Save. Save the performance
recording in C:\CC\Data\.

Antwort:

Begründung:
See the complete Steps below in Explanation
Explanation:
To record the performance of the Property Transactions dashboard in the NYC Property Transactions.twbx workbook and analyze
it using a bar chart, follow these detailed steps:
Open the NYC Property Transactions Workbook:
From the desktop, double-click the NYC Property Transactions.twbx workbook to open it in Tableau Desktop.
Start Performance Recording:
Before doing anything else, navigate to the 'Help' menu in Tableau Desktop.
Select 'Settings and Performance', then choose 'Start Performance Recording'.
Open the Property Transactions Dashboard and Reset Filters:
Navigate to the Property Transactions dashboard within the workbook.
Reset all filters to show all values. This usually involves selecting the dropdown on each filter and choosing 'All' or using a 'Reset'
button if available.
Stop the Performance Recording:
Go back to the 'Help' menu.
Choose 'Settings and Performance', then select 'Stop Performance Recording'.
Tableau will automatically open a new tab displaying the performance recording results.
Save the Performance Recording:
In the performance recording results tab, go to the 'File' menu.
Click 'Save As' and navigate to the C:\CC\Data\ directory.
Save the file, ensuring it is stored in the desired location.
Create a New Worksheet for Performance Analysis:
Return to the NYC Property Transactions workbook and create a new worksheet by clicking on the 'New Worksheet' icon.
Drag the 'Command Name' field to the Columns shelf.
Drag the 'Elapsed Time' field to the Rows shelf.
Ensure that the 'Worksheet' field is also included in the analysis to break down the time by individual sheets within the dashboard.
Choose 'Bar Chart' from the 'Show Me' options to display the data as a bar chart.
Customize and Finalize the Bar Chart:
Adjust the axes and labels to clearly display the information.
Format the chart to enhance readability, applying color coding or sorting as needed to emphasize sheets with longer load times.
Save Your Work:
Once the new worksheet and the performance recording are complete, ensure all work is saved.
Navigate to the 'File' menu and click 'Save', confirming that changes are stored in the workbook.
References:
Tableau Help Documentation: Provides guidance on how to start and stop performance recordings and analyze them.
Tableau Visualization Techniques: Offers tips on creating effective bar charts for performance data.
By following these steps, you have successfully recorded and analyzed the performance of the Property Transactions dashboard,
providing valuable insights into how each component of the dashboard contributes to the overall load time. This analysis is crucial for
optimizing dashboard performance and ensuring efficient data visualization.



60. Frage 
A multi-national company wants to have a Tableau dashboard that will provide country-level information for both its forecast
summaries and year-on-year metrics. The company wants to toggle between these two views while leaving main key performance
indicators (KPIs) visible on the main dashboard.
Which method is the most efficient in achieving the company's requirements?

A. Create a single worksheet with all the measures required for both the forecast summary and the year-on-year views.
. Create a Boolean parameter and a corresponding calculated field with the following calculation: True.
. Add a blank dashboard object and in the Layout tab, check the box for "Control visibility using value" and select the
parameter you created.
B. Create a dashboard with the sheets containing the main KPIs and the forecast summary worksheet.
. Duplicate this dashboard and replace the forecast view worksheet with the year-on-year metrics worksheet.
. Add navigation buttons to both dashboards.
C. Create a parameter that accepts values from a list that contains "Forecast View" and "Year-on-Year View."
. Right-click the parameter and select Add to Sheet for both worksheets.
. Navigate back to the dashboard and to the upper corner of the two worksheets.
. Enable the Use as Filter option.
D. Create a Boolean parameter with the two names of the views as aliases and a corresponding calculated field with the
following calculation: True.
. Add the forecast summary sheet to the dashboard and add the year-on-year metrics sheet to the same dashboard as a
Floating dashboard object.

Antwort: D

Begründung:
. Add the calculated fields as a Detail under the Marks card of the floating view, create a "Change Parameter" action, and set the
"Target Parameter" and "Source Fields" to the parameter and calculated field you created.
. Check the box for "Control visibility using value" in the Layout tab of the floating view and select the parameter you created.
Explanation:
The most efficient method for toggling between two views (forecast summaries and year-on-year metrics) while keeping main KPIs
visible involves using a parameter and calculated fields for controlling visibility:
Create a Boolean Parameter: This parameter will have two aliases representing the two views ("Forecast View" and "Year-on-Year
View"). This allows the user to select which view they wish to see directly from the dashboard.
Calculated Field: Create a calculated field that always returns True. This field acts as a constant placeholder to enable the visibility
control tied to the parameter.
Dashboard Setup: Place both the forecast summary and the year-on-year metrics sheets on the dashboard. Set the year-on-year
metrics sheet as a floating object over the forecast summary.
Visibility Control: Use the "Control visibility using value" option in the Layout tab for the floating year-on-year metrics view. Tie this
setting to the Boolean parameter so that changing the parameter will show or hide this view without affecting the main KPIs
displayed on the dashboard.
Interactivity: Implement a "Change Parameter" dashboard action where selecting different options in the dashboard (e.g., clicking on
certain parts) triggers the parameter to change, thus toggling the visible view.
References
This method leverages Tableau's dashboard interactivity features including parameters, calculated fields, and visibility settings, as
recommended in Tableau's user guide on dynamic dashboard design.

61. Frage 
A Tableau Cloud client has requested a custom dashboard to help track which data sources are used most frequently in dashboards
across their site.
Which two actions should the client use to access the necessary metadata? Choose two.

A. Download metadata through Tableau Catalog.
B. Query metadata through the GraphiQL engine.
C. Access metadata through the Metadata API.
D. Connect directly to the Site Content data source within the Admin Insights project.

Antwort: B,C

Begründung:



To track which data sources are used most frequently across a site in Tableau Cloud, the client should use the GraphiQL engine and
the Metadata API. The GraphiQL engine allows for interactive exploration of the metadata, making it easier to construct and test
queries1. The Metadata API provides access to metadata and lineage of external assets used by the content published to Tableau
Cloud, which is essential for tracking data source usage2.
References: The actions are based on the capabilities of the GraphiQL engine and the Metadata API as described in Tableau's
official documentation and learning resources321.

62. Frage 
A Tableau consultant is asked to evaluate a workbook that is slow to respond and make a recommendation on possible
performance improvements. The workbook connects to three extract data sources from an SQL database. The sheets are used in
five dashboards. The consultant runs a performance recording on the workbook and notices that the largest amount of time is spent
on rendering the visualizations.
What is the most effective approach to reduce the workbook's rendering time?

A. Change the dashboards' size to Automatic.
B. Change the connections to live.
C. Update worksheets to reduce the number of records displayed.
D. Filter the unused data before bringing it into the workbook.

Antwort: C

Begründung:
Comprehensive and Detailed Explanation From Exact Extract:
According to Tableau's Performance Optimization guidance, rendering time becomes the largest bottleneck when excessive marks,
dense data, or overly complex visualizations appear on worksheets. Rendering is the last stage in the Tableau Order of Operations
and is directly affected by how many marks must be drawn and how visually complex each view is.
Tableau's performance recommendations explain:
* When a performance recording shows that Rendering is the slowest step, the most effective improvement is to reduce the number
of marks (records) in the view.
* Rendering time is determined by the number of marks, shapes, headers, labels, and visual elements Tableau must draw.
* Reducing the amount of data displayed on each worksheet is the most impactful change when rendering is the dominant delay.
Option B directly aligns with this: updating worksheets to reduce the number of records displayed lowers the number of marks,
reduces visual density, and improves rendering speed.
Option A is not effective because changing dashboard size does not reduce the number of marks.
Option C would degrade performance because live connections are typically slower than extracts.
Option D improves data preparation and may reduce extract load times, but it does not directly address rendering unless the unused
data was contributing to marks in the view. The question indicates the bottleneck is specifically rendering, so reducing marks is the
most appropriate action.
Therefore, the most effective solution to reduce rendering time is to reduce the number of records (marks) displayed on worksheets.
* Tableau Performance Recording guidance describing rendering as the slowest stage when too many marks are present.
* Tableau Performance Checklist recommending reducing the number of marks in views to improve rendering.
* Tableau Desktop help sections on best practices for improving visualization performance when rendering dominates.

63. Frage
......
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