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Thema 1

Business Consulting: For Tableau Consultants, this section involves designing and troubleshooting
calculations and workbooks to meet advanced analytical use cases. It covers selecting appropriate chart
types, applying Tableau’s order of operations in calculations, building interactivity into dashboards, and
optimizing workbook performance by resolving resource-intensive queries and other design-related issues.

Thema 2

Business Analysis: This section of the exam measures skills of Tableau Consultants focusing on evaluating
the current state of analytics within an organization. It covers mapping business needs to Tableau
capabilities, translating analytical requirements to best practices in Tableau, and recommending appropriate
deployment options like Tableau Server or Tableau Cloud. It also includes evaluating existing data
structures for supporting business needs and identifying performance risks and opportunities.

Thema 3

Data Analysis: This domain targets Tableau Consultants to plan and prepare data connections effectively. It
includes recommending data transformation strategies, designing row-level security (RLS) data structures,
and implementing advanced data connections such as Web Data Connectors and Tableau Bridge. Skills in
specifying granularity and aggregation strategies for data sources across Tableau products are emphasized.

Salesforce Certified Tableau Consultant Analytics-Con-301 Prüfungsfragen
mit Lösungen (Q82-Q87):
82. Frage 
SIMULATION
Refer to the exhibit.

From the desktop, open the NYC
Property Transactions workbook.
You need to record the performance of
the Property Transactions dashboard in
the NYC Property Transactions.twbx



workbook. Ensure that you start the
recording as soon as you open the
workbook. Open the Property
Transactions dashboard, reset the filters
on the dashboard to show all values, and
stop the recording. Save the recording in
C:\CC\Data\.
Create a new worksheet in the
performance recording. In the worksheet,
create a bar chart to show the elapsed
time of each command name by
worksheet, to show how each sheet in
the Property Transactions dashboard
contributes to the overall load time.
From the File menu in Tableau Desktop,
click Save. Save the performance
recording in C:\CC\Data\.

Antwort:

Begründung:
See the complete Steps below in Explanation
Explanation:
To record the performance of the Property Transactions dashboard in the NYC Property Transactions.twbx workbook and analyze
it using a bar chart, follow these detailed steps:
Open the NYC Property Transactions Workbook:
From the desktop, double-click the NYC Property Transactions.twbx workbook to open it in Tableau Desktop.
Start Performance Recording:
Before doing anything else, navigate to the 'Help' menu in Tableau Desktop.
Select 'Settings and Performance', then choose 'Start Performance Recording'.
Open the Property Transactions Dashboard and Reset Filters:
Navigate to the Property Transactions dashboard within the workbook.
Reset all filters to show all values. This usually involves selecting the dropdown on each filter and choosing 'All' or using a 'Reset'
button if available.
Stop the Performance Recording:
Go back to the 'Help' menu.
Choose 'Settings and Performance', then select 'Stop Performance Recording'.
Tableau will automatically open a new tab displaying the performance recording results.
Save the Performance Recording:
In the performance recording results tab, go to the 'File' menu.
Click 'Save As' and navigate to the C:\CC\Data\ directory.
Save the file, ensuring it is stored in the desired location.
Create a New Worksheet for Performance Analysis:
Return to the NYC Property Transactions workbook and create a new worksheet by clicking on the 'New Worksheet' icon.
Drag the 'Command Name' field to the Columns shelf.
Drag the 'Elapsed Time' field to the Rows shelf.
Ensure that the 'Worksheet' field is also included in the analysis to break down the time by individual sheets within the dashboard.
Choose 'Bar Chart' from the 'Show Me' options to display the data as a bar chart.
Customize and Finalize the Bar Chart:
Adjust the axes and labels to clearly display the information.
Format the chart to enhance readability, applying color coding or sorting as needed to emphasize sheets with longer load times.
Save Your Work:
Once the new worksheet and the performance recording are complete, ensure all work is saved.
Navigate to the 'File' menu and click 'Save', confirming that changes are stored in the workbook.
References:
Tableau Help Documentation: Provides guidance on how to start and stop performance recordings and analyze them.
Tableau Visualization Techniques: Offers tips on creating effective bar charts for performance data.
By following these steps, you have successfully recorded and analyzed the performance of the Property Transactions dashboard,
providing valuable insights into how each component of the dashboard contributes to the overall load time. This analysis is crucial for
optimizing dashboard performance and ensuring efficient data visualization.



83. Frage 
A client is evaluating which user roles to assign to managers. The managers need to view dashboards, create Data-Driven Alerts,
and perform ad hoc analysis of existing Tableau data sources. A consultant must provide a solution that minimizes licensing costs.
Which role should the consultant recommend be assigned to the managers?

A. Creator
B. Viewer
C. Site Administrator
D. Explorer

Antwort: D

Begründung:
Comprehensive and Detailed Explanation From Exact Extract:
Tableau documentation clearly defines user capabilities per license:
Viewer
* Can view dashboards only.
* Cannot create Data-Driven Alerts.
* Cannot perform ad hoc analysis.# Insufficient.
Explorer
* Can view dashboards.
* Can create Data-Driven Alerts.
* Can perform ad hoc analysis using existing published data sources.
* Does NOT require full creator-level capabilities.# Meets all requirements at lower cost than Creator.
Creator
* Full authoring, data source creation, and prep capabilities.
* Higher cost.# Overkill and violates "minimizes licensing costs."
Site Administrator
* Includes Creator capabilities plus admin privileges.
* Most expensive.# Not appropriate for managers.
Therefore, the correct and most cost-efficient role is Explorer.
* Tableau role capability matrix showing Explorers can create alerts and analyze existing data sources.
* Licensing guidance recommending Explorer for ad hoc analysis without data-source creation.

84. Frage 
A client is migrating their data warehouse. They visualize the data in workbooks hosted on Tableau Server with Tableau Data
Management enabled and want to see how many workbooks will be impacted.
What should the consultant do to quickly identify how many workbooks will be impacted?

A. Open each workbook and identify the data source.
B. Complete the migration and let users report errors as they are noticed.
C. In Tableau Server, select the database from External Assets, then select the Lineage tab.
D. Leverage the Tableau Developer API to query the workbooks' metadata.

Antwort: C

Begründung:
Comprehensive and Detailed Explanation From Exact Extract:
When Tableau Data Management is enabled, Tableau Catalog provides Lineage capabilities that map connections between:
* External databases
* Tables
* Data sources
* Workbooks
* Fields
Tableau documentation states that the Lineage tab for any external asset (such as a database or table):
* Shows all connected workbooks
* Shows dependencies and impact analysis
* Allows admins to instantly assess how many analytics assets will be affected by a data warehouse migration Option A directly uses
Tableau Catalog to perform exactly this task.



Option B is unnecessary because the Catalog lineage tool already provides this information without development effort.
Option C is completely inappropriate because it offers no analysis or planning.
Option D is too time-consuming and unnecessary, especially when Tableau Catalog provides an automated dependency map.
Therefore, the correct method is to use the Lineage tab in External Assets.
* Tableau Catalog lineage documentation showing how to view impacted workbooks.
* External Assets and data source dependency features in Tableau Data Management.
* Impact analysis best practices for data warehouse migration using Tableau Catalog.

85. Frage 
A consultant wants to improve the performance of reports by moving calculations to the data layer and materializing them in the
extract.
Which calculation should the consultant use?

A. ZN([Sales])*(1 - ZN([Discount]))
B. SUM([Profit])/SUM([Sales])
C. POWER(ZN(SUM([Sales]))/
LOOKUP(ZN(SUM([Sales])), FIRST()),ZN(1/(INDEX()-1)))
- 1
D. CASE [Sector Parameter]
WHEN 1 THEN "green"
WHEN 2 THEN "yellow"

Antwort: B

Begründung:
END
Explanation:
To improve performance by moving calculations to the data layer and materializing them in the extract, the consultant should choose
calculations that benefit from pre-computation and significantly reduce the load during query time:
Aggregation-Level Calculation: The formula SUM([Profit])/SUM([Sales]) calculates a ratio at an aggregate level, which is ideal for
pre-computation. Materializing this calculation in the extract means that the complex division operation is done once and stored,
rather than being recalculated every time the report is accessed.
Performance Improvement: By pre-computing this aggregate ratio, Tableau can utilize the pre-calculated fields directly in
visualizations, which speeds up report loading and interaction times as the heavy lifting of data processing is done during the data
preparation stage.
References:
Materialization in Extracts: This concept involves pre-calculating and storing complex aggregations or calculations within the Tableau
data extract itself, improving performance by reducing the computational load during visualization rendering.

86. Frage 
A client wants to see data for only the last day in a dataset and the last day is always yesterday. The date is represented with the
field Ship Date.
The client is not concerned about the daily refresh results. The volume of data is so large that performance is their priority. In the
future, the client will be able to move the calculation to the underlying database, but not at this time.
The solution should offer the best performance.
Which approach should the consultant use to produce the desired results?

A. Filter on calculation [Ship Date]={MAX([Ship Date])}.
B. Filter on calculation [Ship Date]=TODAY()-1.
C. Filter on Ship Date field using the Yesterday option.
D. Filter MONTH/DAY/YEAR on [Ship Date] field and use an option to filter to the latest date value when the workbook
opens.

Antwort: B

Begründung:
The best approach to ensure performance while providing data for only the last day (yesterday) in the dataset is to use a calculated
field that filters the data to include only yesterday's date:
Filter on calculation [Ship Date]=TODAY()-1: This calculated field dynamically computes yesterday's date by subtracting one day



from today's date. This approach ensures that each day, only the data for the previous day is loaded, which keeps the volume of
data minimal and improves performance.
Dynamic Date Calculation: The use of TODAY()-1 ensures the filter remains up-to-date with the changing dates, without the need
for manual updates, providing accuracy and timeliness in the dashboard.
This approach is efficient because it avoids the overhead of processing the entire dataset and focuses only on the relevant day's data.
It also aligns with Tableau's capabilities for creating dynamic filters using date functions, as highlighted in the Tableau help
documentation on date calculations and filters.
References
This solution utilizes Tableau's built-in date functions and dynamic calculations to optimize performance, as recommended in
Tableau's performance optimization resources and date calculation guidelines.

87. Frage
......
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