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Topic 1

Data Management: This part focuses on establishing governance and support for published content.
Tableau Consultants are expected to manage data security, publish and maintain data sources and
workbooks, and oversee content access. It includes applying governance best practices, using metadata
APIs, and supporting administration fimctions to maintain data integrity and accessibility.

Topic 2

Data Visualization: This section evaluates the Tableau Consultant’s ability to design effective visual analytics
solutions. It involves creating dashboards and visual reports that enhance user understanding, employing
techniques like dynamic actions and advanced chart types, and ensuring performance optimization for an
interactive user experience.

Topic 3

Data Analysis: This domain targets Tableau Consultants to plan and prepare data connections effectively. It
includes recommending data transformation strategies, designing row-level security (RLS) data structures,

and implementing advanced data connections such as Web Data Connectors and Tableau Bridge. Skills in
specifying granularity and aggregation strategies for data sources across Tableau products are emphasized.

Topic 4

Business Analysis: This section of the exam measures skills of Tableau Consultants focusing on evaluating
the current state of analytics within an organization. It covers mapping business needs to Tableau
capabilities, translating analytical requirements to best practices in Tableau, and recommending appropriate
deployment options like Tableau Server or Tableau Cloud. It also includes evaluating existing data
structures for supporting business needs and identifying performance risks and opportunities.

Topic 5

IT Management: This domain measures skills related to managing Tableau environments. It includes
planning server upgrades, recommending deployment solutions (on-premise or cloud), and ensuring
alignment between technical and business requirements for analytics infrastructure. It also involves
troubleshooting and optimizing system performance relevant to Tableau Server and Cloud deployments.

Salesforce Certified Tableau Consultant Sample Questions (Q16-Q21):

NEW QUESTION # 16
A client wants to view stores serviced by delivery drivers on a map. The have the information provided in the table below:

What does the client need to do to plot exact street addresses on the map?

Answer: B

Explanation:

A. Change the data type of Street Address 1 and Street Address 2 to the Geographic role.
B. Custom geocode the street addresses.

C. Add a Map layer to the visualization.

D. Establish a hierarchy of State > City > Street Address 1 > Street Address 2.

Tableau's built-in geocoding supports only the following geographic roles:

* Country

* State / Province
* County

* City

* Postal Code

* Airport

* Area codes

* Congressional districts, etc.

Tableau does NOT natively geocode street-level addresses.

When a dataset contains street address fields, Tableau will not recognize themas geographic fields because:
* Street Address 1 and Street Address 2 are not valid Tableau geographic roles.

* Tableau cannot automatically translate street text (like "101 Random Place Rd") mto latitude/longitude.
Therefore, to plot street-level points on a map, Tableau requires:

Custom geocoding OR latitude/longitude fields.

Tableau documents that for exact address locations:

* You must either supply latitude and longitude for each address, or

* Use custom geocoding, where the user uploads a .csv with addresses matched to coordinates.




Why the other answer choices are incorrect:

B). Change the data type to Geographic role

Street address fields cannot be assigned a geographic role. Tableau will reject them or not map them
O). Establish a hierarchy

Hierarchies help with drilldown but do not generate geographic coordinates for street addresses.

D). Add a map layer

Map layers allow visual overlays but cannot generate geocoding for address fields.

The only correct way to map street addresses is to custom geocode (or supply lat/long), which matches option A).
* Tableau Geocoding documentation stating street-level addresses are not natively supported.

* Custom Geocoding instructions for mapping exact address points.

* Mapping best practices stating that lat/long or custom geocode files are required for street accuracy.

NEW QUESTION # 17
SIMULATION
Refer to the exhibit.

From the desktop, open the NYC
Property Transactions workbook.

You need to record the performance of
the Property Transactions dashboard in
the NYC Property Transactions.twbx
workbook. Ensure that you start the
recording as soon as you open the
workbook. Open the Property
Transactions dashboard, reset the filters
on the dashboard to show all values, and
stop the recording, Save the recording in
CACC\Data\.

Create a new worksheet in the
performance recording, In the worksheet,
create a bar chart to show the elapsed
time of each command name by
worksheet, to show how each sheet in
the Property Transactions dashboard
contributes to the overall load time.
From the File menu in Tableau Desktop,
click Save. Save the performance
recording in C:\CC\Data\.

Answer:

Explanation:

See the conmplete Steps below in Explanation

Explanation:

To record the performance of the Property Transactions dashboard in the NYC Property Transactions.twbx workbook and analyze
it using a bar chart, follow these detailed steps:

Open the NYC Property Transactions Workbook:

From the desktop, double-click the NYC Property Transactions.twbx workbook to open it in Tableau Desktop.

Start Performance Recording:

Before doing anything else, navigate to the 'Help' menu in Tableau Desktop.

Select 'Settings and Performance', then choose 'Start Performance Recording'.

Open the Property Transactions Dashboard and Reset Filters:

Navigate to the Property Transactions dashboard within the workbook.

Reset all filters to show all values. This usually nvolves selecting the dropdown on each filter and choosing'All' or using a 'Reset'
button if available.

Stop the Performance Recording;

Go back to the Help' menu.

Choose 'Settings and Performance’, then select 'Stop Performance Recording'.

Tableau will automatically open a new tab displaying the performance recording results.

Save the Performance Recording:



In the performance recording results tab, go to the 'File' menu.

Click 'Save As' and navigate to the C:\CC\Data\ directory.

Save the file, ensuring it is stored in the desired location.

Create a New Worksheet for Performance Analysis:

Return to the NYC Property Transactions workbook and create a new worksheet by clicking on the 'New Worksheet' icon.
Drag the 'Command Name' field to the Columns shelf.

Drag the 'Elapsed Time' field to the Rows shelf.

Ensure that the "Worksheet' field is also included in the analysis to break down the time by individual sheets within the dashboard.
Choose 'Bar Chart' from the 'Show Me' options to display the data as a bar chart.

Customize and Finalize the Bar Chart:

Adjust the axes and labels to clearly display the information.

Format the chart to enhance readability, applying color coding or sorting as needed to emphasize sheets with longer load times.
Save Your Work:

Once the new worksheet and the performance recording are complete, ensure all work is saved.

Navigate to the "File' menu and click 'Save', confirming that changes are stored in the workbook.

References:

Tableau Help Documentation: Provides guidance on how to start and stop performance recordings and analyze them.

Tableau Visualization Techniques: Offers tips on creating effective bar charts for performance data.

By following these steps, you have successfully recorded and analyzed the performance of the Property Transactions dashboard,
providing valuable insights into how each component of the dashboard contributes to the overall load time. This analysis is crucial for
optimizing dashboard performance and ensuring efficient data visualization.

NEW QUESTION # 18

A data analyst sets up a calculation to filter a dashboard so that it displays only the users' information. The dashboard will then be
published to Tableau Cloud.

The data analyst plans to use the following calculation to filter the data: USERNAME() = [Correct Answer] Which column in the
table below should the data analyst reference in the calculation?

e A. Lower case Name
e B. Emil
o (. Abbreviated Name

Answer: B

Explanation:

When dashboards are published to Tableau Cloud, the function USERNAME() returns the user's Tableau Cloud username, which is
the email address associated with their Tableau Cloud account.

Tableau documentation states:

* On Tableau Cloud, the value returned by USERNAME() is always the user's email address.

* Row-Level Security (RLS) is typically implemented using a comparison of USERNAME() to an email field in the data source.
* For secure filtering, the field compared to USERNAME() must match the authentication identity exactly.

Looking at the provided table:

* "Abbreviated Name" contains short custom codes like "SMiller," which do not match Tableau Cloud usernames.

* "Lower Case Name" contains names like "sean miller," which also do not match Tableau Cloud usernames.

* "Email" contains the full email address for each user, such as "Sean.Miller@superstore.com," which is the only field that
corresponds to what USERNAME() returns in Tableau Cloud.

Therefore, the correct field to reference is Email.

* Tableau Cloud authentication documentation stating USERNAME() returns the user's email address.

* Row-Level Security setup guidance recommending the comparison USERNAME() = [Email Field].

* Tableau security practices indicating only the email colunmn will match USERNAME() values on Tableau Cloud.

NEW QUESTION # 19

A client wants to migrate their Tableau Server to Tableau Cloud. The Tableau Server is configured with three sites: Finance,
Strategy, and Marketing, A consultant must provide a solution that minimizes user impact and costs.

‘Which configuration should the consultant recommend for Tableau Cloud to meet the client's requirements?

e A One Tableau Cloud instance configured with a Finance project folder, Strategy project folder, and Marketing project
folder



¢ B. One Tableau Cloud instance with two sites for Strategy and Marketing, and one Tableau Server instance for Finance
¢ (. Three separate Tableau Cloud instances for Finance, Strategy, and Marketing
¢ D. One Tableau Cloud instance configured with all workbooks in a single project

Answer: A

Explanation:

To minimize user impact and costs while migrating from Tableau Server to Tableau Cloud with muiltiple sites, the best solution is:
Single Tableau Cloud Instance with Multiple Projects: Instead of multiple sites which could imply higher management overhead and
possibly higher costs, configuring one Tableau Cloud instance with different project folders for each former site (Finance, Strategy,
Marketing) is most efficient.

Benefits: This setup maintains organizational separation of data and access similar to having different sites but leverages the unified
management and simplicity of a single cloud instance. It reduces complexity in user access managenment and integration points.
Implementation: Each project folder acts like a mini-site within the larger instance, where specific permissions and content can be
managed independently, akin to the original server setup but within a single cloud-based environment.

References

This recommendation is in line with best practices for cloud migration focusing on consolidation and cost efficiency, as suggested in
Tableau's official documentation for cloud migration strategies.

NEW QUESTION # 20

A consultant migrated a data source to improve performance. The consultant wants to identify which workbooks need to be
updated to point to the new data source.

‘Which Tableau tool should the consultant use?

A. Tableau Advanced Management
B. Activity Log

C. Prep Conductor

D. Data Management

Answer: A

Explanation:

To identify which workbooks need to be updated to point to a new data source after a migration, a consultant should use Tableau
Advanced Management. This component of Tableau provides comprehensive management capabilities including the ability to track
workbook dependencies and data source usage across your entire Tableau environment. Using Tableau Advanced Management
allows consultants to assess the impact of changes in the data source on connected workbooks and efficiently manage updates.

NEW QUESTION # 21
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