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certification.

Salesforce Analytics-Con-301 Exam Syllabus Topics:

Topic Details

Topic 1

Data Management: This part focuses on establishing governance and support for published content.
Tableau Consultants are expected to manage data security, publish and maintain data sources and
workbooks, and oversee content access. It includes applying governance best practices, using metadata
APIs, and supporting administration functions to maintain data integrity and accessibility.

Topic 2

IT Management: This domain measures skills related to managing Tableau environments. It includes
planning server upgrades, recommending deployment solutions (on-premise or cloud), and ensuring
alignment between technical and business requirements for analytics infrastructure. It also involves
troubleshooting and optimizing system performance relevant to Tableau Server and Cloud deployments.

Topic 3

Business Analysis: This section of the exam measures skills of Tableau Consultants focusing on evaluating
the current state of analytics within an organization. It covers mapping business needs to Tableau
capabilities, translating analytical requirements to best practices in Tableau, and recommending appropriate
deployment options like Tableau Server or Tableau Cloud. It also includes evaluating existing data
structures for supporting business needs and identifying performance risks and opportunities.

Topic 4

Business Consulting: For Tableau Consultants, this section involves designing and troubleshooting
calculations and workbooks to meet advanced analytical use cases. It covers selecting appropriate chart
types, applying Tableau’s order of operations in calculations, building interactivity into dashboards, and
optimizing workbook performance by resolving resource-intensive queries and other design-related issues.

Salesforce Certified Tableau Consultant Sample Questions (Q75-Q80):
NEW QUESTION # 75 
A client wants to produce a visualization to show quarterly profit growth and aggregated sales totals across a number of product
categories from the data provided below.
Which set of charts should the consultant use to meet the client's requirements?

A. Scatter plot and pie chart
B. Gantt and bar charts
C. Line and bubble charts
D. Waterfall chart and tree map

Answer: D

Explanation:
To effectively display quarterly profit growth and aggregated sales totals across different product categories, a combination of a
Waterfall chart and a Tree Map is recommended:
* Waterfall Chart: This chart type is excellent for visualizing the sequential growth or decline of profits across different quarters for
each sub-category. It clearly shows how profits accumulate over time, highlighting both positive and negative changes, which makes
it ideal for tracking profit growth or decline through the quarters.
* Tree Map: A Tree Map can efficiently display aggregated sales totals where each block size represents the total sales of a product
category, providing a quick, visually impactful comparison across categories. This is especially useful when the client wants to
understand which categories contribute most to sales in a glanceable format.
Together, these charts provide a comprehensive overview of both profit trends over time (Waterfall Chart) and a comparative
snapshot of sales performance across categories (Tree Map), meeting the client's need to analyze performance dynamics in a
detailed yet consolidated manner.
References
These recommendations are based on common best practices for data visualization in Tableau, where specific chart types are
chosen for their strengths in communicating certain types of data relationships and dynamics, as detailed in Tableau's official
visualization guides.
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NEW QUESTION # 76 
A client wants to see data for only the last day in a dataset and the last day is always yesterday. The date is represented with the
field Ship Date.
The client is not concerned about the daily refresh results. The volume of data is so large that performance is their priority. In the
future, the client will be able to move the calculation to the underlying database, but not at this time.
The solution should offer the best performance.
Which approach should the consultant use to produce the desired results?

A. Filter on calculation [Ship Date]=TODAY()-1.
B. Filter on calculation [Ship Date]={MAX([Ship Date])}.
C. Filter on Ship Date field using the Yesterday option.
D. Filter MONTH/DAY/YEAR on [Ship Date] field and use an option to filter to the latest date value when the workbook
opens.

Answer: A

Explanation:
The best approach to ensure performance while providing data for only the last day (yesterday) in the dataset is to use a calculated
field that filters the data to include only yesterday's date:
Filter on calculation [Ship Date]=TODAY()-1: This calculated field dynamically computes yesterday's date by subtracting one day
from today's date. This approach ensures that each day, only the data for the previous day is loaded, which keeps the volume of
data minimal and improves performance.
Dynamic Date Calculation: The use of TODAY()-1 ensures the filter remains up-to-date with the changing dates, without the need
for manual updates, providing accuracy and timeliness in the dashboard.
This approach is efficient because it avoids the overhead of processing the entire dataset and focuses only on the relevant day's data.
It also aligns with Tableau's capabilities for creating dynamic filters using date functions, as highlighted in the Tableau help
documentation on date calculations and filters.
References
This solution utilizes Tableau's built-in date functions and dynamic calculations to optimize performance, as recommended in
Tableau's performance optimization resources and date calculation guidelines.

NEW QUESTION # 77 
A Tableau consultant is asked to evaluate a workbook that is slow to respond and make a recommendation on possible
performance improvements. The workbook connects to three extract data sources from an SQL database. The sheets are used in
five dashboards. The consultant runs a performance recording on the workbook and notices that the largest amount of time is spent
on rendering the visualizations.
What is the most effective approach to reduce the workbook's rendering time?

A. Change the connections to live.
B. Change the dashboards' size to Automatic.
C. Filter the unused data before bringing it into the workbook.
D. Update worksheets to reduce the number of records displayed.

Answer: D

Explanation:
Comprehensive and Detailed Explanation From Exact Extract:
According to Tableau's Performance Optimization guidance, rendering time becomes the largest bottleneck when excessive marks,
dense data, or overly complex visualizations appear on worksheets. Rendering is the last stage in the Tableau Order of Operations
and is directly affected by how many marks must be drawn and how visually complex each view is.
Tableau's performance recommendations explain:
* When a performance recording shows that Rendering is the slowest step, the most effective improvement is to reduce the number
of marks (records) in the view.
* Rendering time is determined by the number of marks, shapes, headers, labels, and visual elements Tableau must draw.
* Reducing the amount of data displayed on each worksheet is the most impactful change when rendering is the dominant delay.
Option B directly aligns with this: updating worksheets to reduce the number of records displayed lowers the number of marks,
reduces visual density, and improves rendering speed.
Option A is not effective because changing dashboard size does not reduce the number of marks.
Option C would degrade performance because live connections are typically slower than extracts.
Option D improves data preparation and may reduce extract load times, but it does not directly address rendering unless the unused



data was contributing to marks in the view. The question indicates the bottleneck is specifically rendering, so reducing marks is the
most appropriate action.
Therefore, the most effective solution to reduce rendering time is to reduce the number of records (marks) displayed on worksheets.
* Tableau Performance Recording guidance describing rendering as the slowest stage when too many marks are present.
* Tableau Performance Checklist recommending reducing the number of marks in views to improve rendering.
* Tableau Desktop help sections on best practices for improving visualization performance when rendering dominates.

NEW QUESTION # 78 
From the desktop, open the CC workbook.
Open the Incremental worksheet.
You need to add a line to the chart that
shows the cumulative percentage of sales
contributed by each product to the
incremental sales.
From the File menu in Tableau Desktop, click
Save.

Answer:

Explanation:
See the complete Steps below in Explanation:
Explanation:
To add a line showing the cumulative percentage of sales contributed by each product to the incremental sales in the Incremental
worksheet of your Tableau Desktop, follow these detailed steps:
* Open the CC Workbook and Access the Worksheet:
* From the desktop, double-click on the CC workbook to open it in Tableau Desktop.
* Navigate to the Incremental worksheet by clicking on its tab at the bottom of the window.
* Calculate Cumulative Sales Percentage:
* Create a new calculated field to compute the cumulative percentage of sales. Right-click in the Data pane and select 'Create
Calculated Field'.
* Name this field "Cumulative Sales Percentage".
* Enter the following formula to calculate the running sum of sales as a percentage of the total sales:
(RUNNING_SUM(SUM([Sales])) / TOTAL(SUM([Sales])) [Sales]))
* Click 'OK' to save the calculated field.
* Add the Cumulative Sales Percentage Line to the Chart:
* Drag the "Cumulative Sales Percentage" field to the Rows shelf, placing it next to the existing Sales measure.
* Ensure that the cumulative line appears as a continuous line. Right-click on the "Cumulative Sales Percentage" field on the Rows
shelf, select 'Change Chart Type', and choose 'Line'.
* Adjust the axis to synchronize or dual-axis if necessary. Right-click on the axis of the
"Cumulative Sales Percentage" and select 'Synchronize Axis' if it's on a dual-axis setup.
* Format the Cumulative Sales Percentage Line:
* Click on the "Cumulative Sales Percentage" line in the visualization.
* Navigate to the 'Format' pane to adjust the line style, thickness, and color to make it distinct from other data in the chart.
* Save Your Changes:
* From the File menu, click 'Save' to ensure all your changes are stored.
References:
Tableau Help: Provides additional details on creating calculated fields and customizing line charts.
Tableau User Guide: Offers extensive instructions on formatting charts, including line types and axis synchronization.
By following these steps, you will successfully add a cumulative sales percentage line to your chart, enhancing the visualization to
reflect the incremental contribution of each product to the overall sales in a dynamic and informative manner.

NEW QUESTION # 79 
SIMULATION
Refer to the exhibit.
From the desktop, open the NYC
Property Transactions workbook.
You need to record the performance of
the Property Transactions dashboard in



the NYC Property Transactions.twbx
workbook. Ensure that you start the
recording as soon as you open the
workbook. Open the Property
Transactions dashboard, reset the filters
on the dashboard to show all values, and
stop the recording. Save the recording in
C:\CC\Data\.
Create a new worksheet in the
performance recording. In the worksheet,
create a bar chart to show the elapsed
time of each command name by
worksheet, to show how each sheet in
the Property Transactions dashboard
contributes to the overall load time.
From the File menu in Tableau Desktop,
click Save. Save the performance
recording in C:\CC\Data\.

Answer:

Explanation:
See the complete Steps below in Explanation
Explanation:
To record the performance of the Property Transactions dashboard in the NYC Property Transactions.twbx workbook and analyze
it using a bar chart, follow these detailed steps:
Open the NYC Property Transactions Workbook:
From the desktop, double-click the NYC Property Transactions.twbx workbook to open it in Tableau Desktop.
Start Performance Recording:
Before doing anything else, navigate to the 'Help' menu in Tableau Desktop.
Select 'Settings and Performance', then choose 'Start Performance Recording'.
Open the Property Transactions Dashboard and Reset Filters:
Navigate to the Property Transactions dashboard within the workbook.
Reset all filters to show all values. This usually involves selecting the dropdown on each filter and choosing 'All' or using a 'Reset'
button if available.
Stop the Performance Recording:
Go back to the 'Help' menu.
Choose 'Settings and Performance', then select 'Stop Performance Recording'.
Tableau will automatically open a new tab displaying the performance recording results.
Save the Performance Recording:
In the performance recording results tab, go to the 'File' menu.
Click 'Save As' and navigate to the C:\CC\Data\ directory.
Save the file, ensuring it is stored in the desired location.
Create a New Worksheet for Performance Analysis:
Return to the NYC Property Transactions workbook and create a new worksheet by clicking on the 'New Worksheet' icon.
Drag the 'Command Name' field to the Columns shelf.
Drag the 'Elapsed Time' field to the Rows shelf.
Ensure that the 'Worksheet' field is also included in the analysis to break down the time by individual sheets within the dashboard.
Choose 'Bar Chart' from the 'Show Me' options to display the data as a bar chart.
Customize and Finalize the Bar Chart:
Adjust the axes and labels to clearly display the information.
Format the chart to enhance readability, applying color coding or sorting as needed to emphasize sheets with longer load times.
Save Your Work:
Once the new worksheet and the performance recording are complete, ensure all work is saved.
Navigate to the 'File' menu and click 'Save', confirming that changes are stored in the workbook.
References:
Tableau Help Documentation: Provides guidance on how to start and stop performance recordings and analyze them.
Tableau Visualization Techniques: Offers tips on creating effective bar charts for performance data.
By following these steps, you have successfully recorded and analyzed the performance of the Property Transactions dashboard,
providing valuable insights into how each component of the dashboard contributes to the overall load time. This analysis is crucial for
optimizing dashboard performance and ensuring efficient data visualization.
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