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It will improve your skills to face the difficulty of the Analytics-Con-301 exam questions and accelerate the way to success in IT filed
with our latest study materials. Free demo of our Analytics-Con-301 dumps pdf can be downloaded before purchase and 24/7
customer assisting support can be access. Well preparation of Analytics-Con-301 Practice Test will be closer to your success and
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Salesforce Certified Tableau Consultant Sample Questions (Q44-Q49):
NEW QUESTION # 44 
A multi-national company wants to have a Tableau dashboard that will provide country-level information for both its forecast
summaries and year-on-year metrics. The company wants to toggle between these two views while leaving main key performance
indicators (KPIs) visible on the main dashboard.
Which method is the most efficient in achieving the company's requirements?

A. Create a parameter that accepts values from a list that contains "Forecast View" and "Year-on-Year View."
. Right-click the parameter and select Add to Sheet for both worksheets.
. Navigate back to the dashboard and to the upper corner of the two worksheets.
. Enable the Use as Filter option.
B. Create a dashboard with the sheets containing the main KPIs and the forecast summary worksheet.
. Duplicate this dashboard and replace the forecast view worksheet with the year-on-year metrics worksheet.
. Add navigation buttons to both dashboards.
C. Create a Boolean parameter with the two names of the views as aliases and a corresponding calculated field with the
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following calculation: True.
. Add the forecast summary sheet to the dashboard and add the year-on-year metrics sheet to the same dashboard as a
Floating dashboard object.
D. Create a single worksheet with all the measures required for both the forecast summary and the year-on-year views.
. Create a Boolean parameter and a corresponding calculated field with the following calculation: True.
. Add a blank dashboard object and in the Layout tab, check the box for "Control visibility using value" and select the
parameter you created.

Answer: C

Explanation:
. Add the calculated fields as a Detail under the Marks card of the floating view, create a "Change Parameter" action, and set the
"Target Parameter" and "Source Fields" to the parameter and calculated field you created.
. Check the box for "Control visibility using value" in the Layout tab of the floating view and select the parameter you created.
Explanation:
The most efficient method for toggling between two views (forecast summaries and year-on-year metrics) while keeping main KPIs
visible involves using a parameter and calculated fields for controlling visibility:
Create a Boolean Parameter: This parameter will have two aliases representing the two views ("Forecast View" and "Year-on-Year
View"). This allows the user to select which view they wish to see directly from the dashboard.
Calculated Field: Create a calculated field that always returns True. This field acts as a constant placeholder to enable the visibility
control tied to the parameter.
Dashboard Setup: Place both the forecast summary and the year-on-year metrics sheets on the dashboard. Set the year-on-year
metrics sheet as a floating object over the forecast summary.
Visibility Control: Use the "Control visibility using value" option in the Layout tab for the floating year-on-year metrics view. Tie this
setting to the Boolean parameter so that changing the parameter will show or hide this view without affecting the main KPIs
displayed on the dashboard.
Interactivity: Implement a "Change Parameter" dashboard action where selecting different options in the dashboard (e.g., clicking on
certain parts) triggers the parameter to change, thus toggling the visible view.
References
This method leverages Tableau's dashboard interactivity features including parameters, calculated fields, and visibility settings, as
recommended in Tableau's user guide on dynamic dashboard design.

NEW QUESTION # 45 
SIMULATION
Use the following login credentials to sign in
to the virtual machine:
Username: Admin
Password:
The following information is for technical
support purposes only:
Lab Instance: 40201223
To access Tableau Help, you can open the
Help.pdf file on the desktop.

From the desktop, open the CC workbook.
Open the Categorical Sales worksheet.



You need to use table calculations to
compute the following:
. For each category and year, calculate
the average sales by segment.
. Create another calculation to
compute the year-over-year
percentage change of the average
sales by category calculation. Replace
the original measure with the year-
over-year percentage change in the
crosstab.
From the File menu in Tableau Desktop, click
Save.

Answer:

Explanation:
See the complete Steps below in Explanation
Explanation:
To compute the required calculations and update the worksheet in Tableau Desktop, follow these steps:
Compute Average Sales by Segment for Each Category and Year:
Open the CC workbook and navigate to the Categorical Sales worksheet.
Drag the 'Sales' field to the Rows shelf if it's not already there.
Drag the 'Segment' field to the Rows shelf as well, placing it next to 'Category' and 'Year'.
Right-click on the 'Sales' field in the Rows shelf and select 'Quick Table Calculation' > 'Average'. This will compute the average
sales for each segment within each category and year.
Create a Calculation for Year-over-Year Percentage Change:
Right-click in the data pane and select 'Create Calculated Field'.
Name the calculated field something descriptive, e.g., "YoY Sales Change".
Enter the formula to calculate the year-over-year percentage change:
(ZN(SUM([Sales])) - LOOKUP(ZN(SUM([Sales])), -1)) / ABS(LOOKUP(ZN(SUM([Sales])), -1)) Click 'OK' to save the
calculated field.
Replace the Original Measure with the Year-over-Year Percentage Change in the Crosstab:
Remove the original 'Sales' measure from the view by dragging it off the Rows shelf.
Drag the newly created "YoY Sales Change" calculated field to the Rows shelf where the 'Sales' field was originally.
Format the "YoY Sales Change" field to display as a percentage. Right-click on the field in the Rows shelf, select 'Format', and
adjust the number format to percentage.
Save Your Changes:
From the File menu, click 'Save' to ensure all your changes are stored.
References:
Tableau Help: Offers guidance on creating calculated fields and using table calculations.
Tableau Desktop User Guide: Provides instructions on formatting and saving worksheets.
These steps allow you to manipulate data within Tableau effectively, using table calculations to analyze trends and changes in sales
data by category and segment over years.

NEW QUESTION # 46 
A client wants to produce a visualization to show quarterly profit growth and aggregated sales totals across a number of product
categories from the data provided below.



Which set of charts should the consultant use to meet the client's requirements?

A. Scatter plot and pie chart
B. Line and bubble charts
C. Gantt and bar charts
D. Waterfall chart and tree map

Answer: D



Explanation:
To effectively display quarterly profit growth and aggregated sales totals across different product categories, a combination of a
Waterfall chart and a Tree Map is recommended:
Waterfall Chart: This chart type is excellent for visualizing the sequential growth or decline of profits across different quarters for
each sub-category. It clearly shows how profits accumulate over time, highlighting both positive and negative changes, which makes
it ideal for tracking profit growth or decline through the quarters.
Tree Map: A Tree Map can efficiently display aggregated sales totals where each block size represents the total sales of a product
category, providing a quick, visually impactful comparison across categories. This is especially useful when the client wants to
understand which categories contribute most to sales in a glanceable format.
Together, these charts provide a comprehensive overview of both profit trends over time (Waterfall Chart) and a comparative
snapshot of sales performance across categories (Tree Map), meeting the client's need to analyze performance dynamics in a
detailed yet consolidated manner.
References
These recommendations are based on common best practices for data visualization in Tableau, where specific chart types are
chosen for their strengths in communicating certain types of data relationships and dynamics, as detailed in Tableau's official
visualization guides.

NEW QUESTION # 47 
For a new report, a consultant needs to build a data model with three different tables, including two that contain hierarchies of
locations and products. The third table contains detailed warehousing data from all locations across six countries. The consultant
uses Tableau Cloud and the size of the third table excludes using an extract.
What is the most performant approach to model the data for a live connection?

A. Joining the tables in Tableau Desktop
B. Joining the tables in Tableau Prep
C. Relating the tables in Tableau Desktop
D. Blending the first two tables with the third

Answer: C

Explanation:
For a performant live connection in Tableau Cloud, especially when dealing with large datasets that preclude the use of extracts,
relating the tables in Tableau Desktop is the recommended approach. This method allows for flexibility in how the data is queried
and can improve performance by leveraging Tableau's relationships feature, which optimizes queries for the underlying database.
References: The best practices for live connections in Tableau Cloud suggest using relationships to manage complex data models
efficiently1. Additionally, Tableau's documentation on connecting data sources recommends using relationships for better
performance with live connections2.

NEW QUESTION # 48 
A client is concerned that a dashboard has experienced degraded performance after they added additional quick filters. The client
asks a consultant to improve performance.
Which two actions should the consultant take to fulfill the client's request? Choose two.

A. Ensure filters are set to display "Only Relevant Values" instead of "All Values in Database."
B. Modify filters to include an "Apply" button.
C. Use Filter Actions instead of quick filters.
D. Add existing filters to Context.

Answer: B,C

Explanation:
Comprehensive and Detailed Explanation From Exact Extract:
Quick filters are one of the most expensive features in Tableau because they require queries to populate value lists and dynamic
recalculations when filters change.
According to Tableau performance documentation:
1. Add an "Apply" Button
This prevents Tableau from re-running queries every time the user selects a filter value.
Queries are executed once when the user presses Apply.
This is a documented best practice for filter-heavy dashboards.



2. Replace Quick Filters with Filter Actions
Filter actions are far more efficient because:
* They leverage the existing view context
* They do not require separate filter UI queries
* They avoid the overhead of quick filter value lists
Tableau recommends using filter actions instead of multiple quick filters for better performance.
Why the other options are incorrect:
* B. Add filters to Context: Context filters make downstream filters faster, but do not reduce quick filter processing cost; they can
even increase extract size and slow down the dashboard.
* C. Only Relevant Values: This actually slows performance because Tableau must re-evaluate the entire data set to determine
relevancy every time filters update.
Thus, A and D are the correct performance-improvement approaches.
* Tableau Performance Checklist recommending Apply button for multi-select filters.
* Performance documentation advising the use of Filter Actions over multiple quick filters.
* Filtering best practices explaining the cost of Only Relevant Values.

NEW QUESTION # 49
......
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